Welcome, %1$s. Please login or register.
September 30, 2014, 07:48:45 AM
: SMF - Just Installed

+  The SuperManager Forum
|-+  Main Category
| |-+  General
| | |-+  SM crashes if I try to add a product to manual invoice.
« previous next »
: [1]
: SM crashes if I try to add a product to manual invoice.  ( 1373 )
advancedmart
Newbie
*
: 26


« : February 28, 2012, 11:08:19 AM »

SM crashes if I try to add a product to manual invoice.  I took a look under the products section and it looked corrupt, some were empty the others were mixed together.  SO I deleted all the products and then updated.  it looks ok but When I try to add it still gives me .  Unknown error has occored SM was forced to close.   Is there a way to  reset the products or is the whole database messed up?
David Johns
Administrator
Hero Member
*****
: 1834


MSN Messenger - david@thesupermanager.com AOL Instant Messenger - SuperWare+LLC
« #1 : February 28, 2012, 03:13:51 PM »

Can you give me step by step instructions on how to repeat the issue you are having?  I've tried to add items to manual orders and don't see this behavior.

As far as deleting products and importing them new, you just need to do what I think you already did.  The only thing that was not clear from your explanation is if you went to the "All" tab of the product list when you selected all and deleted them.  As long as you did, it would fully clear and start over again with the product list.

There is likely not any general corruption with your database.  It may just be that something specific with your products triggers this behavior.  I'll try to repeat it with the steps you outline and if that doesn't work, I may need you to send me your database so I can repeat the error so that I can correct it.

Thanks,
David

SuperManager Support
info@thesupermanager.com
advancedmart
Newbie
*
: 26


« #2 : February 28, 2012, 11:38:46 PM »

All I did was click on the add Item button from within any order and the window disappears and I get the error message    about force close and that it created a recovered.sbk file.   I tried the ALL product delete and the the numbers match when I reload so it looks like they all go and load back. Actually the products now look ok I don't see the corruption as before but the program will still force close if I click on the add item button.   I also upgraded after this happened. to 1.5.0.0 and it still does the same thing.   

Do you have a way to start a log within the program?

advancedmart
Newbie
*
: 26


« #3 : March 02, 2012, 12:44:53 PM »

Thanks for your help,  after trying many things.   I ended up restoring to a previous restore point in windows.  It took me back to an old version of SM Which i updated to new version.  Everything functions now. I'm not sure  what was causing the problem, a new driver installed or a corrupt on my OS?  The restore point seems to have brought it back to a working state.   

Super manager support could not duplicate it using my file, so it must have been something unique to my OS.
David Johns
Administrator
Hero Member
*****
: 1834


MSN Messenger - david@thesupermanager.com AOL Instant Messenger - SuperWare+LLC
« #4 : March 02, 2012, 05:14:10 PM »

John,

I'm glad you were able to get back up and running.  It must be that something corrupted on of the Microsoft Foundation Class libraries that SuperManager uses or something of that nature.

Thanks,
David

SuperManager Support
info@thesupermanager.com
: [1]  
« previous next »
:  



Powered by MySQL Powered by PHP SMF 2.0.8 | SMF © 2014, Simple Machines Valid XHTML 1.0! Valid CSS!